Overview:
The end-user cannot open the Account Summary tab on the CRM for iPad, because the following error message appears:
There are no data provider IDs for the specified account.
Root Cause:
The cause of the error is there is no Company Product Analytics Product Group is assigned to the Analytics Market, which is why the Analytics data does not get downloaded to the device of the end-user.
The Analytics synchronization is based on the My Setup Product records. In the event the application does not find a match between the My Setup Product records of the end-user and the Product Group Map records, the Analytics data will not be downloaded.
Solution:
- Assign a Company Product Analytics Product Group to the Analytics Market.
- Ensure Product_Group_Map_vod records exist for all Analytics_Product_Group_vod records marked as company products. This is required so users can view sales data for the markets that correspond to their aligned company products.
- After these steps, ask the end-user to perform a Database refresh on their device.
Related Documentation:
CRM Help Documentation:
Knowledge Article: