Overview:
When clicking the Generate Sign In Sheet button on the Events Management (EM) Event page in CRM Online, one txt file named ERROR_xxx (the name of the Sign In Sheet template) is created on the Notes & Attachments related list:
When viewing the file, the following error is displayed:
Unable to generate sign in sheet. Please make sure the following values are populated:
For example:
Root Cause:
There are several possible reasons:
- The user does not have the Field Level Security (FLS) to the fields that are listed in the file
- There is no value for the fields that are listed in the file. However, the optional tag <O> is not inserted into the token in the Sign In Sheet template.
- There are extra spaces in the token.
Example:
Solution:
To resolve this issue:
- Grant FLS permission to the user on the fields that are listed in the file
- Add the optional tag <O> to the token if the field is not required in the Sign In Sheet template
- Delete extra spaces from the token
Related Documentation:
CRM Help Documentation: Managing Event Materials