Overview:
A user's sync does not complete successfully. The following error is recorded in the activity logs:
"sObject type 'Veeva_Settings_vod__c' is not supported. If you are attempting to use a custom object, be sure to append the '__c' after the entity name. Please reference your WSDL or the describe call for the appropriate names."
Root Cause:
The Restrict Access to Custom Settings schema setting is enabled and the user does not have access to the Veeva Settings Custom Settings definition.
Solution:
Ensure all users have access to the VeevaSettingsService Apex class. This class automatically provides access to Veeva-delivered custom settings in Salesforce, if and only if, a user does not already have any custom setting definitions granted through profile or permission sets.
If a user is granted access to at least one custom setting definition, the user must be manually granted access to all Veeva-delivered custom settings definitions, or the user's profile must have the View All Custom Settings administrative permission.
Related Documentation:
CRM Help: Veeva Custom Settings