Overview:
User goes to Sent Email from Account, selects an Email Template, Adds Selected Email Template and an error appears below the account Recipient.
Error: There are no Consent_Header _vod records applicable for this Account. Please review your Consent Capture setup.
Root Cause:
The Consent Header Country field must match the User’s Country field where User’s country is defined in the address section.
Solution:
Set the Country field on the Consent Header to match the User's Country.
If Consent Capture is not being configured at the Country level, the Country needs to be removed from the User Detail.
Related Documentation:
CRM Help Documentation: Consent Capture Overview