Overview:
Even though toggles are changed in Consent Capture, the change is not saved when it is checked again by clicking on Consent Capture (toggles are in original state). No Multichannel Consent record is created.
Root Cause:
The user does not have permission to edit the Account. In the Territory Settings it is set to: By default, users in a territory can view accounts assigned to the territory.
Solution:
- Go to Setup --> Manage territories --> Territory Settings --> Account Access.
- Select the radio button: By default, users in a territory can view and edit accounts assigned to the territory.
- Save.
- Be sure to Clear Veeva Cache before checking the behavior.
Related Documentation:
CRM Help Documentation: Consent Capture