Overview:
The Consent Capture page is not displaying Consent Online when there are Multichannel Consent records for an Account.
Root Cause:
Check that the Capture_Datetime_vod__c or Opt_Expiration_Date_vod__c are not populated for dataloaded records.
Solution:
When data loading Multichannel Consent records the following is true:
- Capture_Datetime_vod__c is required
- Opt_Expiration_Date_vod__c should be populated if there is current Consent for the Account.
Take the following actions as needed:
- Populate the Capture_Datetime_vod__c field on all records.
- Populate the Opt_Expiration_Date_vod__c field if the record has a current Consent record.
Additional Tips:
- Opt Type needs to be populated to the picklist item API name accordingly.
- Populate the Consent Type lookup
- Consent Line is required if the related Consent Header/Consent ype have one
- Content type is needed if the consent setup is based on Content Type
- Product is needed if the consent set up is based on products.
- The record type needs to match the relevant consent type record type.
Related Documentation:
CRM Help Documentation: Consent Capture Overview