Overview:
The following article explains the Consent Header Display Logic on the Consent Capture UI from the perspective of Countries. It presents two common issues, which may or may not occur on both Online and Offline CRM Platforms.
Quoting Creating Consent Headers:
Displaying Consent Header Logic
Not all consent headers display when a user navigates to the Consent Capture screen from an account. Different consent headers display for different accounts depending on the country fields for the consent headers, the account, and the user. Consent admins should understand the following logic to ensure the appropriate consent headers display for an account:
- If the account’s country is specified, consent headers with matching country fields display
- If the account’s country is unspecified OR there are no consent headers matching the account’s country, consent headers matching the user’s country display
- If the account’s country is unspecified AND there are no consent headers matching the user’s country, consent headers with unspecified country fields display
The Country_vod field on the Consent_Header_vod object is a lookup field to a Country_vod record. When selecting the appropriate consent header, the consent header logic matches the account or user’s country to different fields on the Country_vod record depending on the platform:
- iPad, Online: Alpha_2_Code_vod
- Windows: Name
Issue #1
The Consent Capture page is blank or broken online or offline. This is in relation with Point #5 of the following article: The Consent Capture User Interface is Blank or Broken in Veeva CRM Online
Issue #2
The Consent Header Display Logic is not functioning properly as expected. Specific Consent Headers may or may not appear.
Root Cause:
Both issues may be caused by the blank values of the Alpha_2_code_vod__c and Country_Name_vod__c fields on the Country_vod__c object.
In the following screenshot (Salesforce Inspector), the fields can be seen populated with DE and DE on the top.
Furthermore, these issues may occur in case the Country field and/or Country_vod__c fields are not populated on the User and/or Account records. The exact Consent Display requirement is determined by the Customer.
In both cases, respective OLS (Object), FLS (Field), record access, VMOC (VMobile Object Configuration) Setup (Offline) are required.
Solution:
- These two fields on the Country_vod__c object are required to be populated to ensure the expected behaviour.
- Ensure to populate the Country field value of the User record and/or the Country_vod__c field on the Account record.
- Ensure to provide the appropriate access, OLS, FLS, record access.
- Be sure to set up the VMOC records accordingly, the Country_vod__c object requires a VMOC record.
Related Documentation:
CRM Help Documentation:
Knowledge Article: