Overview:
Upon creating a single Opt In / Opt Out record, Content Type field is not populated on the Multichannel Consent record.
Root Cause:
Edit FLS is missing on the Content Type field on Multichannel Consent object for the end user.
Solution:
Grant Edit FLS to the end user on Content Type field on Multichannel Consent object:
- Click on the affected user's Profile.
- Go to the Field-Level Security section.
- Click on View next to Multichannel Consent.
- Click on Edit, check Edit Access next to Content Type.
- Click on Save, Clear Veeva Cache.
Related Documentation:
CRM Help Documentation: Configuring Consent Capture