Overview:
A Customer has a set of Account records automatically opted-in despite there are no Multi-Channel Consent records captured for those Accounts. Approved Email can be sent without capturing Consent records.
Root Cause:
The Account.Approved_Email_Opt_Type_vod field is populated with a value Implicit_Opt_In_vod.
Implicit_Opt_In_vod=’Opt-in Not Required’. This determines if an opt-in record is required or not.
Solution:
This is working as intended. When this picklist is NULL, the Account inherits the consent type from the MULTICHANNEL_EXPLICIT_OPT_IN Approved Email setting. When populated with one of the following values, this picklist overrides the setting, enabling more granular control over an account's consent type:
- Explicit_Opt_in_vod – Sets the Consent Type to Opt-in Required
- Implicit_Opt_In_vod – Sets the Consent Type to Opt-in Not Required
- Never_vod – Sets the Consent Type to Never Email
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