Overview:
Consent Capture works Online, however in Offline the Consent Capture screen is empty. The toggles are not visible at all.
Root Cause:
This issue is related to one of the following:
- The Consent Header does not have a Record Type associated with it
- The Approved_Email_Opt_Type_vod__c field is set to Never_vod
Solution:
Be sure to associate the Record Type to the Consent Header (e.g.: Consent_Header_Default_vod) and be sure the user has access to the Record Type:
- Go to the user profile.
- Go to Record Type Settings.
- Click Edit under Consent Headers.
- Add the associated Record Type to the Selected Record Types.
- Click on Save.
- Clear Veeva Cache.
- Make a full Database Refresh.
Change the value of Approved_Email_Opt_Type_vod__c field on the Account record to blank or to Explicit_Opt_In_vod or remove Field Level Security (FLS) completely for the end-user.
Related Documentation:
CRM Help Documentation: Consent Capture Overview