Overview:
Consent Capture is configured to require a signature for Offline platforms or Paper Consent Id for Online platform. Offline platform behaves as expected, requiring a signature to update consent. But, Online platform does not display the Paper Consent Id field and the consent record can be saved without the Paper Consent Id.
Root Cause:
The end-user does not have Edit permission to the Multichannel_Consent_vod__c object.
Solution:
Grant the end-user Edit permission for the Multichannel_Consent_vod__c object through the Profile or Permission Set.
Related Documentation:
CRM Help Documentation: Consent Capture Overview