Overview:
Double Opt-In confirmation emails are not sent from CRM when Consent is captured.
Root Cause:
The Multichannel_Route_vod record related to the Double Opt-In Consent Type is incorrectly configured.
Access is missing to the Product record related to the Approved Email Template.
Solution:
The Multichannel_Route_vod record must be configured as follows:
- Multichannel_Route_vod.Record_Type = Double_Opt_In_Confirmation_vod
- Multichannel_Route_vod.Object_vod = Multichannel_Consent_vod__c
- Multichannel_Route_vod.Record_Type_Name_vod = RecordType API Name of the Consent_Type_vod record for which Double Opt-In has been enabled
- Record Type of the referenced Approved_Document_vod record = Email_Receipt_vod
Be sure that the user has visibility to the Product_vod record linked to the Approved_Document_vod record.
Related Documentation:
CRM Help Documentation: Using Double Opt-In