Overview:
A Multichannel Consent Record is not created after the consent is captured. The following error occurs in the Network section of the browser developer tool while submitting the consent record: Product: id value of incorrect type: null.
Root Cause:
The Record Type of the Consent Line that the user captures consent for is Product_vod. There is no Product associated with the corresponding Consent Line record.
Solution:
- Populate the Product_vod__c field on the Consent Line record with the proper Product.
- Clear Veeva Cache.
- Have the database refreshed for offline devices.
Related Documentation:
CRM Help Documentation: Consent Capture Overview